Comparte en Facebook Twitter Google+

Recientemente, Composer realizó una actualización modificando la manera en cómo funciona pre-update-command  lo que causaría un fallo en la instalación de Laravel.

Para solucionarlo simplemente debes modificar el archivo composer.json de tu proyecto de Laravel moviendo php artisan clear-compiled  a  post-update-command  y eliminando pre-update-cmd  quedando de esta manera:

Esto debido a que como no existe el archivo composer.lock hace que se ejecute en la instalación inicial un composer update disparando el pre-update-cmd  mientras que antes de la actualización de Composer se ejecutaba era un pre-install-cmd .

Nota: Esta solución aplica a todas las versiones de Laravel: 4.2, 5.0, 5.1 y 5.2

Material relacionado

Regístrate hoy en Styde y continua mejorando tus habilidades: ver planes.